import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\newcommand)\\{?([A-Za-z]*?)";
final String string = "\\documentclass{article}\n"
+ "\\newcommand\\hello[1]{Hello, #1!}\n"
+ "\\begin{document}\n"
+ "\\hello{world} % says hello\n"
+ "\\end{document}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}