#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^\w\s*]+"
Local $sString = "John%%%* dadidou"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)