use strict;
my $str = 'John%%%* dadidou';
my $regex = qr/[^\w\s*]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";