using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\w\s*]+";
string substitution = @"";
string input = @"John%%%* dadidou";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}