package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\w\s*]+`)
var str = `John%%%* dadidou`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}