# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^.{3}|(?!^)\G)\K./*/gm;t' <<< "apple
google
abc12345
asdddd
aa"