$re = '/(^.{3}|(?!^)\G)\K./m';
$str = 'apple
google
abc12345
asdddd
aa';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;