use strict;
my $str = 'apple
google
abc12345
asdddd
aa';
my $regex = qr/(^.{3}|(?!^)\G)\K./mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";