#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^.{3}|(?!^)\G)\K."
Local $sString = "apple" & @CRLF & _
"google" & @CRLF & _
"abc12345" & @CRLF & _
"asdddd" & @CRLF & _
"aa"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)