#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?=.*?sno[^0-9a-z]?(\S+))(?=.*?sname[^0-9a-z]?(\S+))"
Local $sString = "sno-101 sname-smith" & @CRLF & _
"sno*101 sname-smith" & @CRLF & _
"sname-smith sno_101" & @CRLF & _
"sname*dog sno909"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")