$re = '/(?=.*?sno[^0-9a-z]?(\S+))(?=.*?sname[^0-9a-z]?(\S+))/i';
$str = 'sno-101 sname-smith
sno*101 sname-smith
sname-smith sno_101
sname*dog sno909';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);