import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*?sno[^0-9a-z]?(\\S+))(?=.*?sname[^0-9a-z]?(\\S+))";
final String string = "sno-101 sname-smith\n"
+ "sno*101 sname-smith\n"
+ "sname-smith sno_101\n"
+ "sname*dog sno909";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}