import re
regex = re.compile(r"(?=.*?sno[^0-9a-z]?(\S+))(?=.*?sname[^0-9a-z]?(\S+))", flags=re.IGNORECASE)
test_str = ("sno-101 sname-smith\n"
"sno*101 sname-smith\n"
"sname-smith sno_101\n"
"sname*dog sno909")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")