using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*yellow.*(*SKIP)(*F)|^.*\bblue\b(?=.*brown).*$";
string input = @"yellow blue brown // shouldn't match
f blue brown // should match
sdff blue brown // should match
asdf f blue c // shouldn't match
yellow blue fblue b f brown // shouldn't match
sdff blue brown yellow // shouldn't match
purple blue brown";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}