re = /.*yellow.*(*SKIP)(*F)|^.*\bblue\b(?=.*brown).*$/m
str = 'yellow blue brown // shouldn\'t match
f blue brown // should match
sdff blue brown // should match
asdf f blue c // shouldn\'t match
yellow blue fblue b f brown // shouldn\'t match
sdff blue brown yellow // shouldn\'t match
purple blue brown'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end