$re = '~.*yellow.*(*SKIP)(*F)|^.*\bblue\b(?=.*brown).*$~m';
$str = 'yellow blue brown // shouldn\'t match
f blue brown // should match
sdff blue brown // should match
asdf f blue c // shouldn\'t match
yellow blue fblue b f brown // shouldn\'t match
sdff blue brown yellow // shouldn\'t match
purple blue brown';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);