use strict;
my $str = 'yellow blue brown // shouldn\'t match
f blue brown // should match
sdff blue brown // should match
asdf f blue c // shouldn\'t match
yellow blue fblue b f brown // shouldn\'t match
sdff blue brown yellow // shouldn\'t match
purple blue brown';
my $regex = qr~.*yellow.*(*SKIP)(*F)|^.*\bblue\b(?=.*brown).*$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}