package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(apple|mango|banana) is (\d+)kg$`)
var str = `apple is 21kg`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}