$re = '/^(apple|mango|banana) is (\d+)kg$/';
$str = 'apple is 21kg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);