import Foundation
let pattern = #"^(apple|mango|banana) is (\d+)kg$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"apple is 21kg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}