#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<iframe(?!<\/iframe>)[\s\S]*?data-context[\s\S]*?<\/iframe>"
Local $sString = "<iframe src="http://youtube.com"></iframe> " & @CRLF & _
"" & @CRLF & _
"<iframe data-context="whatever" src="http://youtube.com"></iframe> " & @CRLF & _
"" & @CRLF & _
"<iframe src="http://youtube.com"></iframe> <iframe src="http://youtube.com"></iframe> " & @CRLF & _
"" & @CRLF & _
"<p>Potatoes are good</p>" & @CRLF & _
"" & @CRLF & _
"<iframe src="http://youtube.com"></iframe> " & @CRLF & _
"" & @CRLF & _
"<iframe src="http://youtube.com" data-context="whatever"></iframe>" & @CRLF & _
"" & @CRLF & _
"<iframe src="http://youtube.com"></iframe> " & @CRLF & _
"" & @CRLF & _
"<iframe src="http://instagram.com"></iframe> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")