use strict;
my $str = '<iframe src="http://youtube.com"></iframe>
<iframe data-context="whatever" src="http://youtube.com"></iframe>
<iframe src="http://youtube.com"></iframe> <iframe src="http://youtube.com"></iframe>
<p>Potatoes are good</p>
<iframe src="http://youtube.com"></iframe>
<iframe src="http://youtube.com" data-context="whatever"></iframe>
<iframe src="http://youtube.com"></iframe>
<iframe src="http://instagram.com"></iframe> ';
my $regex = qr/<iframe(?!<\/iframe>)[\s\S]*?data-context[\s\S]*?<\/iframe>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}