import Foundation
let pattern = #"<iframe(?!<\/iframe>)[\s\S]*?data-context[\s\S]*?<\/iframe>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<iframe src="http://youtube.com"></iframe>
<iframe data-context="whatever" src="http://youtube.com"></iframe>
<iframe src="http://youtube.com"></iframe> <iframe src="http://youtube.com"></iframe>
<p>Potatoes are good</p>
<iframe src="http://youtube.com"></iframe>
<iframe src="http://youtube.com" data-context="whatever"></iframe>
<iframe src="http://youtube.com"></iframe>
<iframe src="http://instagram.com"></iframe>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)