package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[\s*hl\s*color\s*:\s*(.*?)\s*\](.*?)\[\s*\/\s*hl\s*\]`)
var str = `Some text will be [hl color:yellow]highlighted[/hl] in [hl color: blue]this[/ hl] example.`
var substitution = "<div style="background-color:$1;">$2</div>"
fmt.Println(re.ReplaceAllString(str, substitution))
}