const regex = /\[\s*hl\s*color\s*:\s*(.*?)\s*\](.*?)\[\s*\/\s*hl\s*\]/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\s*hl\\s*color\\s*:\\s*(.*?)\\s*\\](.*?)\\[\\s*\\\/\\s*hl\\s*\\]', 'gi')
const str = `Some text will be [hl color:yellow]highlighted[/hl] in [hl color: blue]this[/ hl] example.`;
const subst = `<div style="background-color:$1;">$2</div>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);