import Foundation
let pattern = #"\[\s*hl\s*color\s*:\s*(.*?)\s*\](.*?)\[\s*\/\s*hl\s*\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Some text will be [hl color:yellow]highlighted[/hl] in [hl color: blue]this[/ hl] example."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<div style="background-color:$1;">$2</div>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)