import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\s*hl\\s*color\\s*:\\s*(.*?)\\s*\\](.*?)\\[\\s*\\/\\s*hl\\s*\\]";
final String string = "Some text will be [hl color:yellow]highlighted[/hl] in [hl color: blue]this[/ hl] example.";
final String subst = "<div style=\"background-color:$1;\">$2</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}