using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>)(\s| )*|(\s| )*(?=<\/)";
string substitution = @"";
string input = @"<p> This is a paragraph.</p><p> This is another paragraph.</p>
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}