re = /(?<=>)(\s| )*|(\s| )*(?=<\/)/
str = '<p> This is a paragraph.</p><p> This is another paragraph.</p>
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result