use strict;
my $str = '<p> This is a paragraph.</p><p> This is another paragraph.</p>
';
my $regex = qr/(?<=>)(\s| )*|(\s| )*(?=<\/)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";