$re = '/(?<=>)(\s| )*|(\s| )*(?=<\/)/';
$str = '<p> This is a paragraph.</p><p> This is another paragraph.</p>
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;