// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{2,3})-(\d{2,3})-(\d{2,3})-(\d{2,3})").unwrap();
let string = "kube_node_info{container_runtime_version=\"docker://18.6.1\",endpoint=\"http\",instance=\"10.11.111.111:8080\",job=\"kube-state-metrics\",kernel_version=\"xxxxx\",kubelet_version=\"xxxx\",kubeproxy_version=\"xxxx\",namespace=\"infra\",node=\"ip-10-11-111-111.us-sdlls-as.compute.internal\",os_image=\"Amazon Linux 2\",pod=\"prometheus-operator-kube-state-metrics-sdfgsjdkgl-saldjl\",service=\"prometheus-operator-kube-state-metrics\"}";
let substitution = "$1.$2.$3.$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}