using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/(www\.google\..+|\w+\.youtube\.com|\w+\.etools\.ch).*$";
string input = @"https://www.google.com/search?q=+vivaldi+archivebox
https://music.youtube.com/account/errror?.jd
https://www.etools.ch/searchSubmit?query=djflaksdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}