import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/(www\\.google\\..+|\\w+\\.youtube\\.com|\\w+\\.etools\\.ch).*$";
final String string = "https://www.google.com/search?q=+vivaldi+archivebox\n"
+ "https://music.youtube.com/account/errror?.jd\n"
+ "https://www.etools.ch/searchSubmit?query=djflaksdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}