$re = '/^https?:\/\/(www\.google\..+|\w+\.youtube\.com|\w+\.etools\.ch).*$/m';
$str = 'https://www.google.com/search?q=+vivaldi+archivebox
https://music.youtube.com/account/errror?.jd
https://www.etools.ch/searchSubmit?query=djflaksdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);