// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https?:\/\/(www\.google\..+|\w+\.youtube\.com|\w+\.etools\.ch).*$").unwrap();
let string = "https://www.google.com/search?q=+vivaldi+archivebox
https://music.youtube.com/account/errror?.jd
https://www.etools.ch/searchSubmit?query=djflaksdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}