package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)("([^"]*)")`)
var str = `Mein Name ist "Joseph"`
var substitution = "„$2“"
fmt.Println(re.ReplaceAllString(str, substitution))
}