import re
regex = re.compile(r"(\"([^\"]*)\")", flags=re.MULTILINE)
test_str = "Mein Name ist \"Joseph\""
subst = "„$2“"
result = regex.sub(subst, test_str)
if result:
print(result)