package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^,]+,[^_]+_(.*?)_[^_]+,.*$`)
var str = `111_2222_33333,222_444_3,aaa_bbb_ccc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}