// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^,]+,[^_]+_(.*?)_[^_]+,.*$").unwrap();
let string = "111_2222_33333,222_444_3,aaa_bbb_ccc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}