$re = '/^[^,]+,[^_]+_(.*?)_[^_]+,.*$/m';
$str = '111_2222_33333,222_444_3,aaa_bbb_ccc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);