re = /^[^,]+,[^_]+_(.*?)_[^_]+,.*$/m
str = '111_2222_33333,222_444_3,aaa_bbb_ccc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end