using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CREATE +?(TEMPORARY +)?TABLE *(?P<db>.*?\.)?(?P<table>.*?)\((?P<col>.*?)\).*?USING +([^\s]+) *(PARTITIONED BY \((?P<pcol>.*?)\))?";
string input = @"CREATE TEMPORARY TABLE db.table (DATA2 int, DATA3 int, DATA4 int) USING parquet PARTITIONED BY (DATA2, DATA3)
CREATE TABLE db.table (DATA2 int, DATA3 int, DATA4 int) USING parquet";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}