import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "CREATE +?(TEMPORARY +)?TABLE *(?P<db>.*?\\.)?(?P<table>.*?)\\((?P<col>.*?)\\).*?USING +([^\\s]+) *(PARTITIONED BY \\((?P<pcol>.*?)\\))?";
final String string = "CREATE TEMPORARY TABLE db.table (DATA2 int, DATA3 int, DATA4 int) USING parquet PARTITIONED BY (DATA2, DATA3)\n"
+ "CREATE TABLE db.table (DATA2 int, DATA3 int, DATA4 int) USING parquet";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}