// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"CREATE +?(TEMPORARY +)?TABLE *(?P<db>.*?\.)?(?P<table>.*?)\((?P<col>.*?)\).*?USING +([^\s]+) *(PARTITIONED BY \((?P<pcol>.*?)\))?").unwrap();
let string = "CREATE TEMPORARY TABLE db.table (DATA2 int, DATA3 int, DATA4 int) USING parquet PARTITIONED BY (DATA2, DATA3)
CREATE TABLE db.table (DATA2 int, DATA3 int, DATA4 int) USING parquet";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}