const regex = /(date_from_to=)(?:.+?)(&)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(date_from_to=)(?:.+?)(&)', 'g')
const str = `posutochnaja-arenda-nedvizhimost-v-yalte/zhk-morskoy-spusk-v-yalte-id20879?date_from_to=01.12.2021-03.12.2021&clear_cache=Y&_r=3298#rooms-header-block`;
const subst = `$1****`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);