re = /(date_from_to=)(?:.+?)(&)/
str = 'posutochnaja-arenda-nedvizhimost-v-yalte/zhk-morskoy-spusk-v-yalte-id20879?date_from_to=01.12.2021-03.12.2021&clear_cache=Y&_r=3298#rooms-header-block'
subst = '$1****'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result