import Foundation
let pattern = #"(date_from_to=)(?:.+?)(&)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"posutochnaja-arenda-nedvizhimost-v-yalte/zhk-morskoy-spusk-v-yalte-id20879?date_from_to=01.12.2021-03.12.2021&clear_cache=Y&_r=3298#rooms-header-block"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1****"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)