using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(foo[^\s]*)";
string substitution = @"<mark>$1</mark>";
string input = @"hello foobar world";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}