$re = '/(foo[^\s]*)/m';
$str = 'hello foobar world';
$subst = "<mark>$1</mark>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;